* ラベル作成 Baseからのデーター読み込みできない [#nd056abb]
 |RIGHT:|LEFT:|c
 |~ページ|[[OpenOffice.org FAQの登録ページ]]|
 |~投稿者|mtbird|
 |~分類|#listbox3(Q&A,faq03,class)|
 |~優先順位|#listbox3(普通,faq03,priority)|
 |~状態|#listbox3(回答中,faq03,state)|
 |~状態|#listbox3(完了回答待ち,faq03,state)|
 |~カテゴリー|#listbox3(Writer ワープロ,faq03,category)|
 |~投稿日|2007-03-01 17:55:40 (木)|
 |~OS|XP|
 |~依存するページ||
 |~バージョン|#listbox3(2.1,faq03,version)|
 
 ** メッセージ [#a7e58f1f]
 |LEFT:|c
 |回答ページでは行末に「~」を付加する必要はありません|
 #contents
 
 BASEでデーターテーブルを作成しています。
 writerでラベルを作成し、データーテーブルを指定してフィールド名までは設定できるのですが、実際に読み込みをしてくれません。
 
 どうしてなのでしょう?
 ラベルの作成に関するページは可能な限り読んで試してみたと思うのですが・・・
 #clear
 
 
 
 ----
 ***実際に行った作業を書いてみてください [#h9c15d54]
 >M.Kamataki (2007-03-02 20:30:30 (金))~
 ~
 OpenOffice.orgのラベル作成は、ちょっと複雑かもしれません。躓いているところを具体的に紹介していただけますか。~
 ~
 また、参考にされたページはどこでしょうか。もし、わたしが書いたものでしたら、もっとわかりやすいように書き換えてみたいと思います。~
 
 //
 ***ありがとうございます。 [#o042aec5]
 >mtbird (2007-03-02 22:48:01 (金))~
 ~
 情報が不足していてすいません。~
 参考にさせていただいたのは、~
 オープンガイドブック OpenOffice.org 2.0 公開版と~
 http://f40.aaa.livedoor.jp/~green/pukiwiki.php?OpenOffice#content_1_18です。~
 ~
 baseで顧客管理を行っています。~
 witerでラベルを作成し、ウィザードに従ってラベルに使用するフィールド、ラベルの書式は設定が出来ました。指示に従って、ラベルを同期するにもチェックを入れてあります。~
 当然ながら、画面上にはフィールド名が明記されたラベルが表示されていますが、プレビューを見ても、印刷を実行してみてもフィールドのデータが表示されません。~
 データーソースを確認するときちんと表示されているので場所の指定や表記は間違っていないと思うのですが、原因がわかりません。~
 ~
 まだ情報が少ないかも知れませんが、よろしくお願いいたします。~
 
 //
 ***印刷結果はどのような症状? [#j7c67bca]
 >M.Kamataki (2007-03-03 12:23:12 (土))~
 ~
 もし、フィールド名が表示されるだけの印刷結果なら、Writerのメニューで[表示]−[フィールド名]がオンになっている可能性があります。オフにしてください。~
 ~
 また、フィールドのデータが印刷されない場合は、ラベルのドキュメントを開いた状態で、ドキュメント上のフィールド名を直接マウスでダブルクリックしてみてください。関連付けされたテーブルのフィールドが「フィールドの編集:データベース」ダイアログで表示されるかどうか、確認してください。~
 ~
 あと、フィールド名の上にマウスを置くと、以下の画像のようにツールチップが表示されます。このツールチップの表示もチェックしてみてください。ファイルパスが含まれていると設定がおかしい可能性があります。~
 ~
 &attachref(faq4_322_01.png,nolink);~
 
 //
 ***やはりだめです・・・ [#jf525473]
 >mtbird (2007-03-04 01:19:40 (日))~
 ~
 表示の項目を確認しましたが、オフになっていました。~
 フィールド名をダブルクリックすると「フィールドの編集:データベース」ダイアログが表示されます。~
 ツールチップも表示されていました。~
 ~
 それでも印刷結果は変わらず・・・~
 <〒><郵便番号>~
 <住所1>~
 <住所2>~
 のようにフィールド名のみでデータに切り替わりません。~
 ~
 いまさらながら基本的なことをたずねますが、ラベル印刷の際に毎回データーテーブルの場所を指定することがあるのでしょうか?~
 メニューの印刷から実行したときに、差し込み印刷の指定があるのでテーブルの場所を尋ねる画面が表示されたことがありました。面倒くさいと思いながら指定してみたら印刷はされたのですが、フィールド名を挿入した際にテーブルの指定は済んでいるはずなのにおかしいなと思いました。~
 その後その画面すら表示されなくなってしまいましたが・・・~
 ~
 もう一度基本的な手順から確認してみたいと思います。~
 ~
 丁寧に教えてくださって感謝します。~
 何か試してみることがあればまた教えてください。~
 
 //
 ***Re: やはりだめです・・・ [#r0fc5023]
 >M.Kamataki (2007-03-05 11:02:32 (月))~
 ~
 >フィールド名をダブルクリックすると「フィールドの編集:データベース」ダイアログが表示されます。~
 さらに割り当てられているテーブル、フィールド名まで表示される必要がありますが、大丈夫でしょうか。~
 ~
 >ラベル印刷の際に毎回データーテーブルの場所を指定することがあるのでしょうか?~
 これは毎回、確認されます。差し込み印刷では、出力するデータの範囲を指定できるようになっていますから。という疑問があるということは、差し込み印刷ウィザードをお使いでしょうか。ラベルの場合は、その作成時にウィザードで設定が済んでいるので、あらためてウィザードを利用するのは面倒ではないでしょうか。シンプルにファイルメニューから「印刷」を選んでいただくのが良いと思います。~
 ~
 なお、データソースにクエリーを指定している場合は、印刷時に自動で割り当てられないので、手動で割り当てる必要があります。~
 
 //
 ***納得しました。 [#lca8315b]
 >Mtbird (2007-03-06 11:17:30 (火))~
 ~
 >なお、データソースにクエリーを指定している場合は、印刷時に自動で割り当てられないので、手動で割り当てる必要があります。~
 ~
 当方はデータソースにクエリーを指定していました。~
 だから毎回割り当てする画面が出て、プレビューでは情報が出なかったんですね。~
 クエリーでも指定せずに一発でラベルを印刷する方法はないのでしょうか?~
 パソコンに詳しくない者が操作することもあるので・・・~
 
 //
 ***現状の解決策 [#t8e6b325]
 >M.Kamataki (2007-03-06 12:28:40 (火))~
 ~
 データソースにビューを指定すれば良いと思います。ビューは、テーブルカテゴリのタスクにある「ビューを作成」メニューを用いると、クエリーと同じように作成できます。(お使いのデータベースエンジンがわかりませんが、MySQLの4.xだとビューは作成できなかったと思います)~
 ~
 なお、この問題に関しては以下のIssueが当てはまると思います。(隠しテキストにも触れているのでちょっとわかりにくく、自信はありませんが、テーブルやビューならOKということは書いてあります)~
 「Conditional text fails with DB-field condition based on queries」~
 http://ja.openoffice.org/issues/show_bug.cgi?id=60950~
 
 //
 ***何度もすいません [#z6955870]
 >Mtbird (2007-03-07 00:32:24 (水))~
 ~
 ビューを指定してもラベル作成できませんでした。~
 どうしてなのでしょうか?~
 
 //
 ***確認をお願いします [#qa35e2d5]
 >M.Kamataki (2007-03-07 10:24:21 (水))~
 ~
 http://ja.openoffice.org/issues/show_bug.cgi?id=60950~
 にあるサンプルでは、ビューを指定することでデータフィールドを用いた差し込み印刷が可能でした。これなら同一条件になるので確認していただけませんか。手順は以下のとおりです。~
 ~
 +testdb.odbをオプションダイアログのメニュー[OpenOffice.org Base]−[データベース]の[新規作成]ボタンをクリックしてデータベースに登録~
 +doctestdb.odtを開いて、[編集]−[データベースの交換]を選択~
 +データベースの交換ダイアログの「使用できるデータベース」欄でtestdbのビュー「View1」を選択~
 <~
 >~
 これで差し込み印刷をしてみてください。~
 ~
 もしできない場合、考えられるのはOpenOffice.orgのバージョンが古いためかもしれません。お使いのバージョンは2.0.1ですよね。Baseは2.0からの新しいアプリケーションなので仕様がマイナーバージョンアップでもかなり変わっています。フォームの日付フィールドの扱いが変更されるなど(現在の日時が自動挿入されなくなった)、困ることもあるかと思いますが。~
 ~
 余談:条件付きの隠しテキストの使い方がわかります。「様」か「御中」を選ぶことに使えるかも~
 
 //
 ***だめでした [#q24ea312]
 >mtbird (2007-03-08 01:54:50 (木))~
 ~
 指示通りやってみましたがだめです。そしてもうひとつ情報で修正したいことがあります。使用していたバージョンですが2.1でした。すいませんでした。最近ダウンロードしたものなので最新版ですよね。(情報を修正しておきました。)~
 ~
 <これで差し込み印刷をしてみてください。~
 とありましたが、これはファイルから印刷を選ぶだけではないのでしょうか?何か特別な操作がありますか?~
 
 //
 ***Re: だめでした [#ud9ab981]
 >M.Kamataki (2007-03-08 18:01:35 (木))~
 ~
 Writerのメニューの[ファイル]−[印刷]を選んでください。「ドキュメントにアドレスデータベースのフィールドが含まれています。差し込み印刷を実行しますか。」というダイアログで[はい]をクリックすると、下図のデータソースのテーブル(ビュー)を表示する画面になります。~
 ~
 &attachref(faq4_322_02.png,nolink);~
 ~
 このとき、ビューなら図のように差し込みデータが表示されるはずです。また、左のデータソースツリーでもビューが自動的に選択されていることを確認できると思います。なお、プリンタドライバー式のPDF作成ソフトで差し込み印刷したものも添付しておきます。~
 
 //
 ***ありがとうございます。 [#ka40b1fe]
 >Mtbird (2007-03-10 00:28:40 (土))~
 ~
 無事に印刷が出来ました。~
 ~
 でも別の問題が発生しました。~
 このままこのページで質問していいのかわかりませんが、会社のPC(インストールしたばかり)では差込印刷を実行しますか?のダイアログが表示されますが、自宅では表示されません。今思えば、以前に「これから表示しない」を選択した気がします。アンインストール&再インストールをしても基に戻りません。どうしたら再設定できるのでしょうか?~
 
 //
 ***オプションの変更が書き込まれたファイル [#gd594fb3]
 >M.Kamataki (2007-03-10 10:30:47 (土))~
 ~
 がどこかにあるはずです。OpenOffice.orgの設定ファイルは「OOoの画面や設定がおかしくなってしまいました。」(faq/1/202)にまとめています。Writerドキュメントに関する設定なので、Writer.xcu あたりだと思います。このファイルをリネームするとダイアログが表示されるようにならないでしょうか。なお、faq/1/202にも書いてありますが、クイック起動も含めてOpenOffice.orgを終了して作業してください。~
 ~
 もし、Writer.xcu でない場合は、問題のある環境をお持ちのMtbird さんに調べていただくしかありません。~
 
 //
 #article