* OpenOffice.org3.2をインストールしてから”no data is available”のエラーが出ます。 [#v1edd818]
 |RIGHT:|LEFT:|c
 |~ページ|[[OpenOffice.org FAQの登録ページ]]|
 |~投稿者|mori|
 |~分類|#listbox3(不具合,faq03,class)|
 |~優先順位|#listbox3(普通,faq03,priority)|
 |~状態|#listbox3(Issues,faq03,state)|
 |~カテゴリー|#listbox3(Base データベース,faq03,category)|
 |~投稿日|2010-02-16 12:03:12 (火)|
 |~OS|Windows XP|
 |~依存するページ|[[Issue #108390>http://ja.openoffice.org/issues/show_bug.cgi?id=108390]] 3.2.1で修正予定|
 |~バージョン|#listbox3(3.2.0,faq03,version)|
 
 ** メッセージ [#n1c23ba5]
 |LEFT:|c
 |回答ページでは行末に「~」を付加する必要はありません|
 Baseのフォームでのデータ入力をしているのですが、~
 3.1では不都合無く使用出来ていたもので、~
 データを入力しているテーブルのフィールドの属性やフィールドタイプも以前と変わりないですし、~
 念のためフォームもウィザードを使用して作成から作り直してみたのですが、症状は変わりません。~
 因みにフォームは新規レコードの追加用なのですが、エラーが出てもレコードは無事追加されています。~
 何か対策があればご教授願いたく書き込みました。~
 宜しくお願いします。
 
 ----
 ***3.2.1で修正予定? [#n1351e9e]
 >M.Kamataki (2010-02-16 14:01:04 (火))~
 ~
 OpenOffice.orgの不具合・要望のデータベースであるIssueTrackerを調べると以下のIssueがありました。このIssueによるとサブフォーム絡みのようです。moriさんのケースと一緒でしょうか。~
 ~
 "No data availlable" for subform~
 http://ja.openoffice.org/issues/show_bug.cgi?id=108390~
 ~
 3.2.1で修正される予定です。また、atjensen さんが作成されたマクロが添付されていて、これを回避策として利用するよう書かれているようです。~
 ~
 なお、当初、このIssueを3.2で修正するよう求めたものの3.2.1に回された経緯は以下のメーリングリストのスレッドに書かれています。~
 ~
 http://www.openoffice.org/servlets/BrowseList?list=releases&by=thread&from=2329262~
 
 //
 ***早速の回答ありがとうございます。 [#q7bbea7f]
 >mori (2010-02-16 14:26:05 (火))~
 ~
 しかし残念ながら、サブフォームを使用したものではありません。~
 atjensen さんが作成されたマクロも拝見させては頂きましたが、使い方が分からないので解決には至っていません。~
 マクロはツール→マクロは見つけましたが、どこに登録して実行するかが分かりませんでした。~
 ~
 3.2.1で修正されるのであれば、暫く待ってみてまだ起こるようであればマクロを使えるように勉強しないとイケないですね。~
 
 //
 ***お試しいただけますか [#h4ebe2a9]
 >M.Kamataki (2010-02-16 17:35:22 (火))~
 ~
 >新規レコードの追加用なのです~
 ~
 とのことなのですが、この設定を過去のレコードの参照もできるように変更すると問題は出なくなるでしょうか。~
 ~
 設定の変更はフォームを編集して、MainForm(名前を変更してない時のデフォルト名)の「フォームの属性」の設定を下図のように「データのみ追加」を「はい」から「いいえ」に変更します。~
 ~
 &attachref(faq5_263_1.jpg,nolink);~
 
 //
 ***”no data is available”は出なくなりました。 [#t244bd2b]
 >mori (2010-02-16 18:03:50 (火))~
 ~
 ありがとうございます。~
 一応これでエラーなくデータの追加は出来るように成りました。~
 ~
 フォームを開けたい際に、過去のレコードが出るため、"新しいレコード"ボタンを押す作業は増えましたが、問題ないです。~
 ~
 3.2.1で修正される問題である事も教えて頂き、打開策まで教えて頂きありがとうございます。~
 ~
 完了とさせて頂きます。~
 
 //
 ***Issue登録済みにしますね [#o32aa93f]
 >M.Kamataki (2010-02-16 18:24:09 (火))~
 ~
 どうも以下のIssueの方がぴったりのようです。~
 ~
 Forms with setting 'Add data Only = Yes' broken~
 http://ja.openoffice.org/issues/show_bug.cgi?id=108377~
 ~
 このIssueは、上記で紹介した#108390への重複ということでクローズされています。「データのみ追加 = はい」とした時の問題とサブフォームの問題は、結局は同じ原因ということです。~
 ~
 上記で紹介したマクロは、マクロのコメントに「insertdFistDataForm、reloadFistDataFormを自分で設置したボタンに割り当てる」というようなことが書かれているようです。フォームの「レコード保存」と「更新」ボタンの替わりに使うという想定だと思います。~
 ~
 なお、#108390は修正済みとなっています。3.2.1を待つ前にいずれ3.2.1となる開発版をインストールするというのも解決策だと思います。開発版は以下のURLで「Get OpenOffice.org Developer Snapshots」をクリックすると入手できます。たぶん、あと1か月くらい先の開発版が無難です。~
 ~
 http://download.openoffice.org/~
 
 //
 ***なるほど、状態は完了だけではなかったのですね。失礼しました。 [#z16577ff]
 >mori (2010-02-17 10:48:43 (水))~
 ~
 度々ありがとうございます。~
 ~
 一ヶ月先の開発版ですね。~
 記憶に残っていれば挑戦したいと思います。~
 ありがとうございます。~
 
 //
 #article