「Web出版サイト」ベータ公開

Q&A集[?]

当サイトでのご質問の受付は終了しました

すべてのコンテンツを読み込み専用としたため、回答欄からも投稿できません

Apache OpenOffice/LibreOfficeのご質問はそれぞれのフォーラムへご投稿ください

質問コーナー

サイト内検索

分類メニュー

関連サイト


本日:1
昨日:0
総数:811
現在:3


Impress上でグラフを加工するとx値がうまく反映されません

ページOpenOffice.org FAQの登録ページ
投稿者matsu
分類
edit/refer
優先順位
edit/refer
状態
edit/refer
カテゴリー
edit/refer
投稿日2009-08-03 19:05:02 (月)
OSWindows XP
依存するページIssue #104163
バージョン
edit/refer

メッセージ

回答ページでは行末に「~」を付加する必要はありません

Calcで作成したグラフをImpressへコピペしたのですが、 グラフ設定の変更のためにグラフをクリックしたり サイズを変更したりするとx軸の値がうまく反映されなりました。

この症状はx軸が複数のデータ列を持っているときに起こるようです。 データテーブルには変更が無いようです。 最近バージョンを1.1.4から3.0.1に変更したばかりなので Impressの設定はほとんどいじってないと思います。

簡単に起きる不具合なので、自分が見落としただけで 回答済みの問題なのかもしれませんが x軸が正しく反映した状態でグラフが加工できる方法を教えてください。


サンプルの添付は可能ですか

M.Kamataki (2009-08-03 23:19:48 (月))

添付していただいた画像で使用されたImpressのファイルをサンプルとして添付していただくことは可能でしょうか。

サンプルです

matsu (2009-08-04 11:43:23 (火))

見ていただきありがとうございます。
Impressファイルを添付しますので確認お願いします。

Re: サンプルです

M.Kamataki (2009-08-05 18:02:24 (水))

サンプルの質問用.odpを拝見しました。

拡大後のグラフをダブルクリックしたところ、正しいグラフに戻りました。その後、拡大後のグラフをダブルクリックしたり、大きさを変えてみたりしたのですが、グラフがおかしくなる現象を確認できません。さて、他に試された方はいらっしゃいませんか。

なお、念のためfaq/1/202「OOoの画面や設定がおかしくなってしまいました。」の対応策を一度、試してみてはどうでしょう。

状況の追加報告

matsu (2009-08-07 11:36:29 (金))

ご指摘いただいたfaq/1/202にあるユーザーファイルの消去を試してみたのですが
状況に変化は見られませんでした。(再インストールも同じく変化なし)

グラフがおかしくなる条件ですが「x軸が複数」ではなく、
「2つのグラフのポイント数が異なる」ことが条件のようです。
私のパソコン上ではどんな数値でも再現できましたので確実だと思います。

環境の違い

M.Kamataki (2009-08-07 18:07:22 (金))

>私のパソコン上ではどんな数値でも再現できましたので確実だと思います。

もしかするとXP SP3をお使いではないでしょうか。XP SP3で起きる問題はVistaでも同じだと思います。XP SP3またはVistaのユーザの方の追試をお願いします。

ちなみにXP SP2だとご質問の問題はおきません。

再現しました

ike@九州 (2009-08-07 18:32:11 (金))

他の案件に掛かりっきりになっていて時間裂けませんでした。m(_ _)m

Vista、XP_SP3
にて再現しました。

ご推察通り、XP_SP2 では再現しませんでした。

ご推察の通り

matsu (2009-08-10 11:28:53 (月))

返信が遅くなってしまいすみません。
M.Kamatakiさんの仰るとおりこちらのOSはXP SP3でした。

不具合に

M.Kamataki (2009-08-11 09:43:34 (火))

検証用マシンにインストールしたWindows 7でもご質問の症状を確認しましたので分類を「不具合」にしました。

XP SP2にバージョンダウンするわけにもいかないでしょうから、OpenOffice.orgの不具合・要望データベースであるIssueTrackerに登録して修正してもらうしかないと思います。

登録方法は、「当サイトの使い方/不具合・要望を出す」を参考にしてください。

ご協力ありがとうございました

matsu (2009-08-11 23:59:22 (火))

Issue Trackerにて不具合報告をしてきました。
(登録時に名前の重複を避けるため名前がyrjxp065となっております)

M.Kamatakiさん、ike@九州さん、
問題の検証およびアドバイスありがとうございました。

Issueにもサンプルを

M.Kamataki (2009-08-12 00:07:45 (水))

どうもありがとうございます。以下のIssueですね。

Scatterplot on OOo Impress doesn't display accurate x data on particular condition.
http://ja.openoffice.org/issues/show_bug.cgi?id=104163

たぶん確認のため、Issueにサンプルを添付するようコメントが付くのではと、思います。当ページのサンプルの「拡大前」「拡大後」を「before」「after」に書き換えたものをアップするとよいのではと思います。

おっと、よく確認すると、URLを参照するよう書かれていますが、参照URL欄が未記入ですね。URL欄は報告者であれば、後からでも入力できるはずです。ログインして、#104163を訪れてください。URL欄にサンプルのあるサイトを入力して、アップデートしてください。もしくは、上記のように新しいサンプルをIssueに添付してもOKです。

Issue追加コメント

matsu (2009-08-13 15:31:14 (木))

M.kamatakiさん、ご指摘ありがとうございます。
担当の方からもURLについて同じ注意が来ました(苦笑)

英語でのサンプルファイルとURL、添付ファイルの追加をしました。

Issueが認められたようです

M.Kamataki (2009-08-14 00:40:46 (金))

wgさんが、ステータスを「未確認」から「新規」に変えてくれました。wgさんは、Issueの窓口係りだと思います。このあと開発の方に担当が替わります。ターゲットが「3.x」ですが、開発担当の方次第でターゲットはまた変わる可能性があります。

何か変更があれば、メールで知らせが届くと思います。登録されたIssueがどのように変化していくのか、見守ってください。わたしもCCしておきました。早く修正されると良いのですが。

お名前:
題名:


添付ファイル: filescatterplot.odp 359件 [詳細] file質問用.odp 329件 [詳細] fileImpress質問.bmp 281件 [詳細]