「Web出版サイト」ベータ公開

Q&A集[?]

当サイトでのご質問の受付は終了しました

すべてのコンテンツを読み込み専用としたため、回答欄からも投稿できません

Apache OpenOffice/LibreOfficeのご質問はそれぞれのフォーラムへご投稿ください

質問コーナー

サイト内検索

分類メニュー

関連サイト


本日:1
昨日:0
総数:996
現在:2


Calcのコメントの編集

ページOpenOffice.org FAQの登録ページ
投稿者こん
分類
edit/refer
優先順位
edit/refer
状態
edit/refer
カテゴリー
edit/refer
投稿日2007-08-25 14:28:32 (土)
OSWindows
依存するページ
バージョン
edit/refer

メッセージ

回答ページでは行末に「~」を付加する必要はありません

Calcのセルに挿入されたコメントで欧文の場合、これを編集しようとすると固まってしまい、強制終了せざるを得なくなります。 但し、これが再現するのは、コメントに言語が設定されていない場合のみで、言語が設定されている場合は編集モードに入ることができます。 サンプルファイル(sample.ods)を添付しますので、ご確認いただけますでしょうか。私が試した数台のPCでは、メニューからコメントの挿入を選ぶか、コメントを選択してF2キーを押すと編集モードに入って固まります。


JSP明朝となってました

ike@九州 (2007-08-27 12:03:04 (月))

添付サンプルを使用しました。
XPSP2、OOo2.21では確かに再現しました
ところが
Vista、OOO2.21では再現せず
フォント名がJSP明朝となっていました(Vistaには該当フォント無し)
JSPフォントは一太郎などでインストールされるフォントのようですね

VectorよりMSフォントからJSPフォントを作り出すソフト
http://www.vector.co.jp/soft/win95/writing/se111961.html
XPSP2に作成したフォントをインストールして開いたところ問題なく編集できました(当然フォント名はJSP明朝と表示されました)
上記ソフトでトラブルが出ないとも限りませんのでご注意ください

推測です
Vistaで再現しなかったのでOOo2.21固有ではなく
OS、Font、アプリ組み合わせのトラブルの一つかもしれませんね。
フォント関連のトラブルは多いようですので出来るだけ問題の起きないフォントの利用がお勧めですね、情報ありがとうございました。

以前のバージョンでは発生しなかったのですが…

こん (2007-08-27 13:48:29 (月))

ike@九州様、ご回答ありがとうございます。
OpenOffice.orgの仕様が変わったのですね。以前のバージョンでは問題なく編集できていました。
私が試したWindowsは、XP2、2000SP4、98SE(英語版)ですが、いずれも駄目でした。Vistaは持っていないので、現段階での編集はお手上げ状態です。

回避方策をご提示頂きありがとうございました。しかしながら、あいにく私の環境(Windows2000SP4)では、フォントインストールまでは行ったものの、それでも編集はできませんでした。

差し支えなければもう少し教えてください。
Calcのコメントのフォントのデフォルトは、どこで設定できるのでしょうか。今までは一切設定したことがないので、何故、サンプルファイルのコメントのフォントがJSP明朝になっていたか不思議です(当該ファイルのどこにも使っていません)。

よろしくお願いします。

わたしのところでは再現しません

M.Kamataki (2007-08-27 15:54:01 (月))

XPSP2、OOo2.2.1で確認しましたが、下図のようにわたしのところでは編集できてしまいました。編集できたので、フォントが「JSP明朝」となっているのもわかります。

faq4_632_01.png

なお、わたしはこんさんの書かれた
>コメントに言語が設定されていない場合のみで、言語が設定されている場合
ここの意味が理解できていません。これはどういう操作でしょうか。

また、添付されたサンプルはこんさんの環境で作成されたものでしょうか。それともどなたからか頂いたものでしょうか。

こんさんの環境だとすると、思い浮かぶのは「OOoの画面や設定がおかしくなってしまいました。」(faq/1/202)です。

わかりました

M.Kamataki (2007-08-27 16:07:48 (月))

スペルチェックがオンだとXPSP2/OOo2.2.1で再現しました(上記添付画像をスペルチェックの状態がわかる画像に差し替え)。これは不具合だと思います。

なお、9月にリリースされる予定の2.3の開発版でもチェックしてみました。こちらでは編集できました。ということで、2.2.1ではスペルチェックのオフで回避、正式には2.3で修正されている、ということになろうかと思います。

2.3を待つこととします

こん (2007-08-27 17:00:39 (月))

M.Kamataki様、ありがとうございました。
言語を設定しているコメントも一緒に入れておけば良かったですね。失礼しました(差し替えておきました)。

私の環境でもスペルチェックオフで回避できることを確認しました。
2.3で改善(原状回復?)されているようですので、それを待つこととします。

サンプルファイルのフォント名として「JSP明朝」が出ていますが、これは和文時のフォントで、コメント(英文)に実際に使用されているフォントは「Thorndale」です。

それにしても、なぜ和文フォント名としてJSP明朝が登場するのかは依然としてなぞです。サンプルファイルはどこにも使っていないのにです。
急ぎませんので、コメントの文字設定(デフォルトの設定)について情報をお持ちの方はお寄せ頂ければ幸いです。

確認不足で失礼しました

ike@九州 (2007-08-28 10:30:41 (火))

Kamatakiさんフォローありがとうございました

コメント1では確かに英数字フォントの言語が空白になってますね
(文字を全て選択後右クリック->文字で確認)
言語に"なし"を選択すると表示スタイルが変わってしまいますが現象再現せず
空白と"なし"では意味合いが違うようです
最初にどのようにしてコメント1を作成されたのでしょうか?同じ書式で作成する事ができません(知識不足です)
他の文書からコピペされたのでしょうか

和文フォントはここで設定変更できましたが、下記のように変更しない限り現象再現。
・文中の")."を")"に変更すると現象起きません

コメント1で"a)."の3文字だけでもクラッシュ
2.3ではこの点が改良されたのでしょうかね

コメントの作成

こん (2007-08-29 19:15:20 (水))

>最初にどのようにしてコメント1を作成されたのでしょうか?同じ書式で作成する事ができません(知識不足です)
>他の文書からコピペされたのでしょうか

サンプルファイルは、私が使用している元ファイルの一部を切り貼りしたものです。元ファイルの前身はOpenOffice.org1xの時代に作ったSXCファイルで、現在はODSに変換して引き続き使用しています。
サンプルファイルでは、「言語設定なし」はそのままの状態でコピー・貼り付けし、「言語設定あり」の方は、貼付後にサンプルファイル上で言語設定を行いました。いずれのセルもSXC時代に作成したセルです。
確認したところ、OpenOffice.org1ではコメントの書式設定ができなかったようです。書式設定ができるようになったのはOpenOffice.org2になってからのようで、その辺りの引き継ぎがうまくいっていないのかも知れません。
ちなみに、元ファイルのSXC時代のファイルを開いて分かりました。当時のファイルでJSP明朝をセルの標準フォントとして使っていたようで、ODSになった以降でセルの標準を別のフォントに変えていたようです。
こんなところ(コメント)に、まだ当時の設定が生きていたのですね。でも、どうやってコメントの標準フォントを変更するのだろう?

詳細ありがとうございました

ike@九州 (2007-08-30 16:19:18 (木))

コメントを新規作成手入力した場合はスタイルと書式での標準の設定フォント(faq/1/243を参照して標準のフォントは変更可)がコメント内のフォントとして適用されますが、OOoドキュメントからコメント内へコピーした場合元のフォント設定が必ず反映される仕様のようです

形式を選択して貼り付けから、書式を含めないでコメント内に貼り付けをしてもフォントはコピー元のものが設定されてしまいました。
これでは新規にコメントを手入力作成し、ツールバーボタンの書式のコピーから既存のコメント毎に書式コピーするしか方法がないのではないでしょうか。
数が多いと一苦労ですね
(はにゃ?さんならマクロで全コメントに書式一括コピーが出来るかもしれません)
faq/3/360 にありますように、OOo1Xのときは言語設定"なし"は空白のようですね(現在の言語設定"なし"とは違う)
言語設定が空白だと、英単語毎で改行でなく英単語の途中改行が出来ています。コレがどうしても新規に出来ませんでした

2.3の修正に該当するIssue

M.Kamataki (2007-09-01 12:05:48 (土))

こんさん、ike@九州さん、いろいろとお調べいただき、ありがとうございます。

2.3の開発版では問題が起きませんが、この修正に該当するIssueを見つけられずにいます。該当Issueがあれば、確実に2.3で修正されていると明言できますが、そういう状態なので、間もなくリリースされる2.3のリリース候補(RC版)をお試しいただけませんか。

英語のメーリングリストでは下記URLのようにすでにインフォメーションされています。
http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=10932

日本では、
ftp://ftp.kddlabs.co.jp/office/openoffice/extended/2.3.0rc1
にミラーされると思います。

確認しました

ike@九州 (2007-09-15 17:52:20 (土))

OOo2.3.0rc1がアップされていたのでXP_SP2にインストールして確認いたしました。
Userフォルダをリネームしてデフォルトで確認したところ、自動スペルチェックオンでSample.odsコメント編集時のフリーズは発生しませんでしたし"any)."でも勿論無問題で一応の解決だと思われます。

コメント内への形式を選択して貼り付け(書式設定されていないテキスト)では残念ながらコピー元のフォント設定が反映され以前と同じでした。
これは要望がまだないのでしょうね。
それと言語設定空白時の英単語途中改行は残しておきたいような書式です。英文の読みやすさは別にしてコメント内での見栄がよさそうなので、この書式は今後誰かのお役にたつかもしれません。

2.3では解決です

こん (2007-09-18 15:07:19 (火))

OpenOffice.org 2.3(日本語版独自ビルド)で試しました(Windows98SE)。スペルチェックを有効にしていずれのコメントの修正を行っても、OpenOffice.orgは固まりませんでした。

>コメント内への形式を選択して貼り付け(書式設定されていないテキスト)では残念ながらコピー元のフォント設定が反映され以前と同じでした。

私の環境でも同様です。いつもエディターに貼り付け、それを切り取って再度コメントに貼り付けていますので、早く改善されることを願っています。

お名前:
題名:


添付ファイル: filesample.ods 725件 [詳細] filefaq4_632_01.png 262件 [詳細]