「Web出版サイト」ベータ公開

Q&A集[?]

当サイトでのご質問の受付は終了しました

すべてのコンテンツを読み込み専用としたため、回答欄からも投稿できません

Apache OpenOffice/LibreOfficeのご質問はそれぞれのフォーラムへご投稿ください

質問コーナー

サイト内検索

分類メニュー

関連サイト


本日:1
昨日:0
総数:1422
現在:2


データラベルのパーセント値表示がおかしい

ページOpenOffice.org FAQの登録ページ
投稿者Linuxおやじ
分類
edit/refer
優先順位
edit/refer
状態
edit/refer
カテゴリー
edit/refer
投稿日2008-04-11 16:12:52 (金)
OSGentoo Linux amd64
依存するページIssue #88075
バージョン
edit/refer

メッセージ

回答ページでは行末に「~」を付加する必要はありません

calcで"A","10" "B","20" "C","30" と入力後、グラフの種類で「積み上げパーセント」、行内のデータ系列、でグラフ化し、その後「オブジェクトの属性」→「データラベル」→「値をパーセントで表示」とすると、本来ならば"A"は16.7%、"B"は33.3%、"C"は50.0%になるはずだが、1000%、2000%、3000%となってしまう。 2.3.1ではちゃんとパーセンテージ表示されていた。 一応サンプルデータを添付しました。ご参考となれば幸です。


追試

Linuxおやじ (2008-04-11 16:54:31 (金))

グラフの種類を「積み上げ」にして「パーセント表示」すると、ちゃんと50%とか表示されました。
また、「積み上げパーセント」で「値を表示」すると、変な値が表示されます。積み上げパーセント時の内部計算処理がおかしいのでしょうか。

windows版2.4でも再現しました

ike@九州 (2008-04-12 08:25:18 (土))

以下でしょうか?
Chart - Label shows value as if it was percentage
http://www.openoffice.org/issues/show_bug.cgi?id=88075
和訳
http://www.excite.co.jp/world/english/web/?wb_url=http://www.openoffice.org/issues/show_bug.cgi?id=88075&wb_lp=ENJA

当面の回避は追試された内容でGOODのようですね

情報ありがとうございます

Linuxおやじ (2008-04-12 23:04:00 (土))

示されたバグ情報の通りっぽいですね。
この英語スレッドの最後に添付されていたpatchを当ててre-buildしたところ、
無事「積み上げパーセント」でもパーセント表示できるようになりました。

ikeさん、ありがとうございました。

patch検証有難うございます

ike@九州 (2008-04-14 08:10:18 (月))

>patchを当ててre-buildしたところ〜表示できるようになりました

素晴らしいです。
自分にはできないので、3.0迄待つ事に…

Issue登録済みに

M.Kamataki (2008-04-14 11:04:35 (月))

Issueへのパッチ登録が4月11日なので、すでに公開されている3.0の開発版ではまだ直っていないでしょうね。ベータ版が夏前には登場すると思うので、Windowsユーザーの方はそちらでご確認ください。

なお、当質問はIssue登録済みにします。

皆様対応有難うございました

Linuxおやじ (2008-04-14 11:19:57 (月))

色々情報を頂けたおかげで、patchも当てることができました。感謝しております>ikeさん

なお、元の英語スレッドにも書かれていますが、他の問題への影響は調べきれておりませんので、今後参考にされる方は注意してください。

これからもよろしくお願いします。

新しいパッチが出ました

M.Kamataki (2008-04-15 16:51:37 (火))

Issue #88075が更新されており、新しいパッチが投稿されました。

このIssueに関心がある方は、投稿やCCをご検討ください。Issueにコメントがあれば、メールで通知を受けることができます。投稿やCCについては、「使い方/不具合・要望を出す」の「5. 実装を待ちます。」をご覧ください。

確認作業中です

Linuxおやじ (2008-04-15 18:09:43 (火))

今、パッチを当て直してre-build中です(多分明日朝には終わっているでしょう ^^;)

中身を見てみましたが、基本的には0411と変わらず、使わなくなった変数を整理しているようです。
後、関連があるとされている#43489(パーセントと値の同時表示)ですが、0411パッチを当てた状態ではきちんと表示(セパレータはカンマを指定)されていました。

0415パッチが当たったら、また試してみます。

ターゲットが2.4.1に

M.Kamataki (2008-04-15 20:40:47 (火))

Issue #88075がさらに更新されて2.4.1がターゲットになりました。2.4.1は、急遽3.0の前にリリースされることになりました。

0415確認しました

Linuxおやじ (2008-04-16 11:34:45 (水))

0415パッチでも大丈夫でした。

本不具合はPDF化やWriterに貼り付けしたときも再計算されるのか値が変化してしまうという、結構重いBUGだと思ってました。

何にせよ、早い修正とリリースはユーザにとってありがたいことです、関係者の皆様、ありがとうございます。

お名前:
題名:


添付ファイル: filesample.ods 546件 [詳細]