「Web出版サイト」ベータ公開

Q&A集[?]

当サイトでのご質問の受付は終了しました

すべてのコンテンツを読み込み専用としたため、回答欄からも投稿できません

Apache OpenOffice/LibreOfficeのご質問はそれぞれのフォーラムへご投稿ください

質問コーナー

サイト内検索

分類メニュー

関連サイト


本日:1
昨日:2
総数:2331
現在:2


テキストアニメーションがスライドショーでうまく表示されない。

ページOpenOffice.org FAQの登録ページ
投稿者匿名
分類
edit/refer
優先順位
edit/refer
状態
edit/refer
カテゴリー
edit/refer
投稿日2009-11-02 15:25:33 (月)
OSWindows XP
依存するページIssue #94392
バージョン
edit/refer

メッセージ

回答ページでは行末に「~」を付加する必要はありません

OOo3.1.1Impressでテキストを右から左に流すように表示したいのですが、スライドショーでうまく表示されません。
テキストボックス右クリックの「テキスト」>「テキストアニメーション」>「効果」に「通過」を設定しています。スライド作成画面とそのスライドのみをスライドショーしたときにはうまくアニメーション付きで表示されるのですが、数枚あるスライドを最初からスライドショーしてそのスライドが表示された場合には、テキストアニメーションを入れてあるはずのところに何も表示されません。
何か設定が悪いのでしょうか?ちなみにグラフィックアクセラレーターのチェックははずしています。
ご存知の方、おられましたら解決方法を教えてください。


確認

ike@九州 (2009-11-02 16:23:11 (月))

メニューの
スライドショー>スライドショーの設定>オプション にて

"アニメーションを入れる" にチェックが必要ではないでしょうか

さっそくのご回答ありがとうございます。

匿名 (2009-11-02 16:39:31 (月))

ご指摘の項目にはチェックが入っております。

他のアニメーションは問題なく表示されるのですが、テキストアニメーションだけうまく表示されません。

無題

ike@九州 (2009-11-02 17:45:07 (月))

こちらで、テキストアニメーションが再生されないのは
上記以外では、右作業パネル>アニメーションの設定にて
該当テキストボックスに別効果を追加している場合だけでした。

サンプル添付が解決に速いような気がします

サンプルの添付をご検討ください

M.Kamataki (2009-11-03 01:05:17 (火))

わたしもサンプルがあったほうが良いと思います。

失礼しました。

匿名 (2009-11-03 23:04:46 (火))

職場のxpで現象が起きたのですが、自宅のvistaでも同じ現象が起きます。
サンプルを添付いたしますので、ご確認ください。

IssueTrackerに登録済みの不具合のようです

M.Kamataki (2009-11-04 11:40:03 (水))

ご提供いただいたサンプルをたまたまOpenOffice.org 2.2.1で実行してみたら、期待通りに動きました。ちなみに2.4.2ではご質問の症状になったので、2.x系のどこかで動かなくなっているようです。

OpenOffice.orgの不具合・要望データベースであるIssueTrackerで調べると以下のIssueが該当するのではと思いました。

Text animation stops working(Impress,Scroll, Slide Show)
http://ja.openoffice.org/issues/show_bug.cgi?id=94392

rkahujaさんのコメントのStep 5で記述されている「Scroll through」というのが「通過」の英語の項目名ですね。修正のターゲットは3.3になっています。

無題

ike@九州 (2009-11-04 12:14:00 (水))

自身の場合、3ページ内の2ページ目でテキストアニメーションを作成していたのですが表示されてました。

で、検証してみると
テキストアニメーションの挿入ページの次ページが存在すると表示されます。
(空のページでも問題ないようです)

次の問題点
テキスト枠と位置情報と、枠内文字の位置情報に内部的な間違いがあるようでテキスト枠のかなり右側から文字表示が始まります。
ので、空のページを挿入しても、流れてくるのを暫く待つ必要がありますし途中位置で消えます。
まれに位置情報に差のないテキストボックスも作成されるようで現象不安定です


空ページを挿入した場合で 2.4.2 ではずれずに正常に表示されました。
3.3 にて全て解決されればよいですね。

ありがとうございました。

匿名 (2009-11-04 12:41:59 (水))

不具合なのですね。
次のバージョンでは改善されていることを期待します。

ike@九州さんに教えていただいた通り、次のスライドを追加してスライドショーすると正常にアニメーションが表示されました。

また、位置のずれなのですが、「テキスト」>「テキストアニメーション」の「終了時にテキストが見える」にチェックを入れると、なぜかずれることなく表示されました。

これで問題なく動作しそうです。M.Kamatakiさん、ike@九州さん、本当にありがとうございました!

不具合にしますね

M.Kamataki (2009-11-04 15:07:10 (水))

回避策もあるようなので、良かったと思います。

Issueの登録があるので不具合にしておきます。

お名前:
題名:


添付ファイル: filesample2.odp 1362件 [詳細] filesample.odp 682件 [詳細]