「Web出版サイト」ベータ公開

Q&A集[?]

当サイトでのご質問の受付は終了しました

すべてのコンテンツを読み込み専用としたため、回答欄からも投稿できません

Apache OpenOffice/LibreOfficeのご質問はそれぞれのフォーラムへご投稿ください

質問コーナー

サイト内検索

分類メニュー

関連サイト


本日:1
昨日:0
総数:2764
現在:8


起動してから数十秒後、異常終了する

ページOpenOffice.org FAQの登録ページ
投稿者柳澤
分類
edit/refer
優先順位
edit/refer
状態
edit/refer
カテゴリー
edit/refer
投稿日2010-06-08 19:27:19 (火)
OSWindows7 64bit
依存するページ
バージョン
edit/refer

メッセージ

回答ページでは行末に「~」を付加する必要はありません

インストールして起動後、最初の一度だけsoffice.bin(.dll?)でランタイムエラーが発生。

※エラーダイアログは保存していません。すいません。

その後は、OpenOfficeを起動できるのですが、数十秒後にはウィンドウが勝手に閉じて、「OpenOffice.orgドキュメントの回復」ダイアログが出るようになりました。

ドキュメントの回復を実行して、もう一度起動すると、同じ現象となります。

ドキュメントの回復ダイアログをそのままにして起動すると、現象は発生しなくなります。

この状態でも、ドキュメントの編集や編集したファイルの保存など問題なく出来るようです(Impressのみ確認)。

現象自体はCalc、Writer、Impressで100%再現します。(他のアプリでは試していません)

IMEは「Google日本語入力」、ウィルス対策は「ウィルスバスター2010」を使用しています。

似た現象の対策として、Jobs.xcu内のAutoCheckEnabledの値をfalseに変更する方法があったので試してみましたが、現象は変わりませんでした。

再インストールはまだ試していません。


64bit PCの問題?

M.Kamataki (2010-06-08 20:57:42 (火))

Vistaですが、OpenOffice.orgの不具合・要望データベースであるIssueTrackerに以下のような報告があります。

Runtime Error soffice.bin
http://ja.openoffice.org/issues/show_bug.cgi?id=109004

どうでしょうか、エラーメッセージは同じでしたか? IssueTrackerでも「未確認」なので、今のところ解決策はなさそうです。

いちおう、ひとつの可能性を消すということで、faq/1/202「OOoの画面や設定がおかしくなってしまいました。」もご覧になり、ユーザー設定ファイルのリネームをお試しください。

なお、
>Jobs.xcu内のAutoCheckEnabledの値をfalseに変更する方法
こちらの情報がどちらで紹介されていたのか、URLがわかりましたら、教えてください。

[一応解決]回答と、Windows7側に問題?

柳澤 (2010-06-09 09:59:13 (水))

ご回答いただきありがとうございます。

>Runtime Error soffice.bin
>エラーメッセージは同じでしたか?
一度しか見ていない(出ていない)ので、はっきり断言できませんが、同じような内容だったと思います。

>ユーザー設定ファイルのリネームをお試しください。
(ユーザーフォルダ)\AppData\Roaming\OpenOffice.org\3を削除してみましたが、現象は変わりませんでした。

>なお、
>>Jobs.xcu内のAutoCheckEnabledの値をfalseに変更する方法
>こちらの情報がどちらで紹介されていたのか、URLがわかりましたら、教えてください。
下記faqを見つけたので、関係あるかな?と思い、試しました。
「起動時に無題1の回復処理を繰り返す」
http://oooug.jp/faq/index.php?faq%2F4%2F1226

その後、再インストールを試そうとしたのですが、下記の理由で私のPCのWindows7自体が壊れている可能性があると分かりました。
・コントロールパネルから「プログラムと機能」を開けなくなっており、他にも開けないコントロールパネルの項目が数個ある。
・実は前日、STOPエラーを出して停止しており、その際システムファイルが(起動は可能な程度に)破壊された恐れがある(CHKDSKはパスしたので、影響ないだろうと思っていて書きませんでした、すみません)。

そこで、CドライブをフォーマットしてWindows7をセットアップし直した後、OpenOffice3.2.1をインストールしてみました。
その結果、ランタイムエラーも、数十秒後に異常終了する現象も出なくなりました。
もし、OpenOfficeとWindows7 64bitとの間の問題だったら、同じような問題が起きると思います。
しかし、今のところは問題なさそうなので、今回はWindowsがクラッシュしていたのが主な原因ではないかと考えます。

もし再現した場合は、また投稿させていただきます。

いったん完了にしておきます

M.Kamataki (2010-06-09 10:28:33 (水))

ご報告ありがとうございます。

よくIssueを見てみたら、表計算ドキュメントのリンクの更新時のエラーメッセージなので、インストールとは関係ないですね。また、「Jobs.xcu内のAutoCheckEnabledの値をfalseに変更する方法」の件は、当サイトの情報でしたか。失礼しました。こちらもLinux関係ですし、問題が解決していないのであまり参考にならないと思いました。

いずれにしてもPCの環境に問題があったようですね。OpenOffice.org側の問題ではないということで、分類等を変更して完了にしておきます。

お名前:
題名: