10月のカレンダー
    123
45678910
11121314151617
18192021222324
25262728293031
最近の日記
全体の新着
各月の日記
ユーザーRSS
hanyaさんの公開日記
11月16日
01:32
LibreOffice の開発が進むにつれて OpenOffice.org との API レベルでの互換性が低下してきました。それは拡張機能についても同じです。マクロやコンポーネントといったものを含まないものにも影響が出始めるかもしれません。

LibreOffice 3.5 から拡張機能パッケージに LO のバージョン依存性を指定できるようになるようです [1]。

[1]: http://wiki.documentfoundation.org/Development/Extension_...

大体、以下のようにして description.xml ファイル内で利用します。
<?xml version="1.0" encoding="UTF-8"?>
<description xmlns="http://openoffice.org/extensions/description/2006"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:lodep="http://libreoffice.org/extensions/description/2011">
<dependencies>
<lodep:LibreOffice-minimal-version value="3.5" lodep:name="LibreOffice 3.5" />
</dependencies>
</description>

この関連のソースコードは desktop/source/deployment/misc/dp_dependencies.cxx にあります。
公開日記トップへ
oooug-jp SNS

●サイドメニュー

  • 公開日記
  • >公開日記はログインしなくても読めます

http://www.ospn.jp/

inetd